Inhaltsverzeichnis

 Top Next

1. Inhaltsverzeichnis

2. Erste Schritte

2.1 Einführung

2.2 Installieren & Deinstallieren

2.3 Programmoberfläche

2.4 Blog einrichten

3. Beiträge verwalten

3.1 Beitrag erstellen und bearbeiten

3.2 Bilder mit dem ImageWizard bearbeiten

3.3 Publizieren

3.4 Bereits veröffentlichte Beiträge bearbeiten

4. Extras

4.1 Notizblock, Textbausteine und Technorati-Tags-Generator

4.2 Optionen

4.3 Vorlagen

4.4 Rechtschreibprüfung

4.5 Programm- und Anwenderverzeichnis

4.6 Daten sichern & übertragen

adobe

Weil sich die Hilfe nur schlecht komplett mit Inhaltsverzeichnis ausdrucken lässt, gibt es sie extra noch mal als Handbuch im druckfreundlichen PDF-Format (Download)


Einführung

 Top Previous Next

Einführung

Ist ein Blogsystem wie WordPress erst einmal installiert und eingerichtet, kann man endlich mit dem Schreiben beginnen. Doch schnell wird klar, dass Formatierungen, der Einsatz von Bildern und andere anspruchsvolle Funktionen recht mühsam und zeitaufwändig sind.

BlogDesk will das Erstellen neuer Beiträge vereinfachen und beschleunigen. Beim Schreiben im WYSIWYG-Editor braucht man sich nicht um verwirrende HTML-Tags kümmern, die Verwendung von Bildern wird zum Kinderspiel und sogar das gleichzeitige Publizieren in mehreren Blogs ist möglich.

Beim Erstellen und Konfigurieren neuer Blogs hilft der Blog-Einrichtungs-Assistent. Danach ist der Einsatz von BlogDesk denkbar einfach, das Bearbeiten und Erstellen von Beiträ gen entspricht dem Umgang mit einer Textverarbeitung.

Nach dem Verfassen eines Beitrages reicht ein Klick, und der fertige Beitrag wird verö ffentlicht. Dazu überträgt BlogDesk den Text (und die darin verwendeten Bilder) auf den Server, wo der neue Beitrag in das Blogsystem integriert wird.


Installieren & Deinstallieren

Installieren

Die Installation ist denkbar einfach: speichern Sie die Installationsdatei (Downloadseite) auf Ihrem Computer in einem beliebigen Verzeichnis. Im Anschluss an den Download müssen Sie die Datei nur noch aufrufen und die Vorgaben des Setup-Programmes bestätigen.

Erneute Installation

Genau so müssen Sie auch dann vorgehen, wenn Sie BlogDesk erneut installieren (z.B. wenn ein Update erschienen ist). Falls Sie bei der Erstinstallation das Programmverzeichnis angepasst haben, müssen Sie bei der erneuten Installation darauf achten, wieder in dieses Verzeichnis zu installieren.

Deinstallieren

Wenn Sie nicht mehr mit BlogDesk arbeiten wollen, können Sie es jederzeit wieder von Ihrem Rechner entfernen. Dafür gibt es ein Deinstallationsprogramm, das sich auf zwei Arten aufrufen lässt:
· Öffnen Sie im Start-Menü die Programmgruppe BlogDesk und führen Sie den Befehl BlogDesk entfernen aus.
· Klicken Sie in der Windows-Systemsteuerung doppelt auf das Symbol Software, wechseln Sie in das Register Installieren/Deinstallieren, markieren Sie den Eintrag BlogDesk und drücken Sie dann die Schaltfläche Entfernen.

Wie viele andere Programme auch, entfernt BlogDesk beim Deinstallieren aus Sicherheitsgründen nur solche Dateien und Verzeichnisse, die vorher installiert wurden. Falls also im Laufe der Nutzung innerhalb des Programmverzeichnisses oder seinen Unterverzeichnissen Dateien erstellt oder abgelegt wurden, werde diese nicht gelöscht - und die Verzeichnisse, in denen sie sich befinden, können dann auch nicht gelöscht werden. Gleiches gilt für das Anwenderverzeichnis und den darin befindlichen Anwenderdaten.

Wenn während Ihrer Arbeit mit BlogDesk Daten entstanden sind, müssen Sie diese also manuell wieder entfernen. Dabei kann es sich um das Programmverzeichnis und das Anwenderverzeichnis handeln (jeweils mit allen Unterverzeichnissen).

Falls Ihnen nicht klar ist, wo sich diese Verzeichnisse befinden, sollten Sie vor der Deinstallation im Menü Hilfe den Befehl Info aufrufen und sich dann Weitere Infos anzeigen lassen, dort finden Sie die entsprechenden Angaben. Danach können Sie BlogDesk deinstallieren und anschließend die genannten Verzeichnisse manuell löschen (z.B. innerhalb des Windows-Explorers).


Programmoberfläche

Programmoberfläche

Die Programmoberfläche enthält folgende Elemente (die im Kapitel Beitrag bearbeiten näher erläutert werden):

blogdesk-gui

1. Menü- und Buttonleiste mit den Schaltflächen zum Erstellen, Öffnen, Speichern, Publizieren und Bearbeiten von Beiträgen.
2. Feld zur Eingabe des Titels.
3. Schaltflächen zum Wechseln zwischen den drei möglichen Sektionen eines Beitrages.
4. Textfeld für die Bearbeitung des eigentlichen Textes.
5. Liste mit den definierten Blogs und deren Kategorien.
6. Beitrags-Optionen.
7. Feld für die Eingabe von Trackbacks.

Die komplette rechte Seite der Programmoberfläche kann im Menü Ansicht über den Befehl Optionen sichtbar versteckt und wieder angezeigt werden. Die reduzierte Ansicht schafft mehr Platz für den eigentlichen Beitrag und fokusiert die Aufmerksamkeit.

Gerade unerfahrene Anwender wissen es zu schätzen, wenn Sie auf dem Bildschirm nicht unnötig abgelenkt werden. Ist ein Blog erst einmal eingerichtet und sind die Standardoptionen festgelegt, dann mag es vollkommen reichen, sich auf den Text des Beitrages zu beschränken.

blogdesk-gui-simple


Blog einrichten

Blog einrichten

Über den Befehl Blogs verwalten im Menü Datei öffnen Sie die Liste der bereits konfigurierten Blogs. Sie können hier Einträge neu erstellen, bearbeiten oder löschen. Außerdem lassen sich vordefinierte Blogs importieren (evtl. stellt Ihnen Ihr Blog-Hoster eine entsprechende Datei zur Verfügung).

Beim Erstellen eines neuen Blogs erscheint zunächst der Blog-Einrichtungs-Assistent. In der Regel müssen Sie hier nur die Adresse Ihres Blogs sowie Login & Passwort eingeben, die restlichen Daten ermittelt der Assistent dann selbständig. Anschließend können Sie sofort Beiträge schreiben und publizieren.

Der Blog-Einrichtungs-Assistent kümmert sich zunächst nur um die wichtigsten Daten für den Kontakt mit dem Blog. Alle weiteren Optionen können Sie in den Blog-Eigenschaften anpassen, die sich über den Schalter Eigenschaften öffnen lassen. Dieses Fenster ist in mehrere Register aufgeteilt.

Register Blog

Die Angaben in diesem Register sind wichtig für den Kontakt zwischen BlogDesk und dem Blogsystem auf dem Server. Hier ein Beispiel:

blogdesk-blog-config-example-1

Host

Hier ist der Name des Servers ohne weitere Zusätze anzugeben. Falls sich Ihr Blog in einem Unterverzeichnis befindet, dürfen Sie dieses hier nicht anhängen.

Beispiele: | mein-erster-blog.de meinserver.com
Falsch: | mein-erster-blog.de/blog

Falls Ihr Blog über eine Subdomain angesprochen wird, ist diese ebenfalls zu nennen.

Beispiele:

blog.meinserver.com

meinblog.bloghost.net

Über den Schalter Mehr gelangen Sie zu einem weiteren Fenster. Dort lassen sich die Zugangsdaten eingeben, falls sich Ihr Blog in einem passwortgeschützten Verzeichnis befindet. Außerdem kann hier eine SSL-Verbindung aktiviert werden (falls diese vom Server unterstützt wird).

Port

Das hängt vom Server ab, der Standardwert ist 80.

Timeout

Legt fest, wieviele Sekunden BlogDesk auf eine Anwort des Servers wartet, bevor ein Fehler angenommen wird.

Login

Tragen Sie hier den Login (Benutzernamen) ein, den Sie auch verwenden, wenn Sie sich innerhalb des Browsers in Ihr Blog einloggen.

Passwort

Tragen Sie hier das Passwort ein, das Sie auch verwenden, wenn Sie sich innerhalb des Browsers in Ihr Blog einloggen.

Blog-ID

Dieser Wert kann entweder manuell eingetragen oder durch den [...]-Schalter ermittelt werden.

RPC-Adresse

Hier ist die relative Adresse der Datei anzugeben, über die BlogDesk mit dem Server kommuniziert (der sog. Entry Point). Der eigentliche Dateiname wird vom verwendeten Blogservice vorgegeben, bei WordPress z.B. ist das XMLRPC.PHP. Die (zum Host relative) Adresse der Datei ergibt sich aus dem Verzeichnis, in dem die Datei auf dem Server liegt.

Beispiele: | /xmlrpc.php | Die Datei liegt direkt im Root-Verzeichnis
 | /blog/xmlrpc.php | Die Datei liegt im Unterverzeichnis blog

Zeichensatz

In dieser Liste müssen Sie den Zeichensatz auswählen bzw. eintragen, der auch serverseitig für das Blog gewählt wurde. Bei WordPress ist das standardmäßig UTF-8, aber gerade in Europa entscheiden sich viele Anwender für ISO-8859-1 oder ähnliche Zeichensätze.

Wichtig ist, dass diese Option der Einstellung innerhalb des Blogsystems auf dem Server entspricht. Ist dies nicht der Fall, wird es zu Problemen mit Sonderzeichen (z.B. den Umlauten) kommen.

Wenn Sie einen Zeichensatz wie ISO-8859-1 verwenden, kann es sinnvoll sein, Sonderzeichen von BlogDesk umwandeln zu lassen (siehe Register Publizieren).

API

Name der Schnittstelle, über die BlogDesk mit dem Server kommuniziert. Möglich sind hier bisher die Werte MetaweblogAPI und MovableType.

System

Name des Systems, auf dem das Blog läuft.

Blog-Adresse (URL)

Die Blog-Adresse ist die Adresse, die ein Leser im Browser eingeben muss, um Ihr Blog zu besuchen.

Register FTP & Upload

Wenn Sie in Ihren Beiträgen Bilder (oder andere Dateien) verwenden, müssen diese beim Publizieren gesondert auf den Server übertragen werden (Upload). Dafür bietet BlogDesk zwei Methoden, die aber nicht von allen Blog-Systemen unterstützt werden.

DirectUpload

Diese Methode ist einfach zu konfigurieren und bietet sich außerdem an, wenn Sie keinen FTP-Zugriff auf Ihr Blog haben. Allerdings unterstützen nicht alle Systeme den direkten Upload.

FTP-Upload

Für diese Methode brauchen Sie FTP-Zugriff auf Ihr Blog (oder auf einen externen FTP-Server)

Register Kategorien

Für ein Blog lassen sich auf dem Server Kategorien erstellen, denen dann die einzelnen Beiträge zugeordnet werden. Damit auch BlogDesk diese Kategorien kennt, müssen Sie hier mindestens einmal den Befehl Beim Server ermitteln ausführen. BlogDesk nimmt dann Kontakt mit dem Server auf und füllt die Liste mit den vorhandenen Kategorien. Diesen Vorgang sollten Sie wiederholen, sobald Sie auf dem Server Kategorien neu erstellen, löschen oder umbenennen.

Ermitteln lassen sich die Kategorien natürlich erst, wenn Sie im Register Blog die nötigen Angaben für den Kontakt mit dem Server gemacht haben.

Falls es beim Ermitteln der Kategorien zu Problemen kommt, können Sie die Liste der Kategorien auch Manuell bearbeiten. Außerdem können Sie die Liste der Kategorien Alphabetisch sortieren lassen.

Wenn Sie in dieser Liste einzelne Kategorien aktivieren, werden diese beim Erstellen eines neuen Beitrages für dieses Blog standarmäßig ausgewählt.

Register Publizieren

In diesem Register finden Sie Optionen, die das Publizieren eines Beitrages betreffen.

Sonderzeichen innerhalb von HTML umwandeln

Wenn Sie ihn Ihrem Blog ISO-8859-1 als Zeichensatz verwenden, kann es evtl. zu Darstellungsproblemen kommen, wenn Sie Umlaute und andere Sonderzeichen direkt verwenden. Diese Probleme treten i.d.R. gar nicht bei Ihnen auf, sondern bei den Lesern Ihres Blogs, die sich in anderen Ländern befinden und andere Browser mit anderen Schriftarten verwenden.

Wenn Sie diese Option aktivieren, werden Ihre Sonderzeichen kompatibler mit anderen Systemen. Nachteil ist, dass die umgewandelten Sonderzeichen stören können, wenn Sie den Beitrag später auf dem Server nachträglich bearbeiten wollen. So werden Sie dort statt Ü die Zeichenfolge &Uuml; finden.

Paragraph-Tags (<p> und <br>) entfernen

Innerhalb von HTML werden einzelne Absätze durch verschiedene Tags getrennt. Nicht alle Blogsysteme mögen diese Tags, und deshalb kann es evtl. zu besseren Ergebnissen führen, wenn Sie diese Tags vor dem Veröffentlichen aus dem Beitrag entfernen.

Auch beim Schreiben im Source-Editor können diese Tags stören. Um die Übersichtlichkeit zu erhöhen, lässt sich deshalb die Anzeige dieser Tags im Source-Editor in den Optionen deaktivieren.

Vor dem Senden auf leere Felder prüfen

Um beim Publizieren eines Beitrages fehlende Angaben zu vermeiden, können Sie hier die betreffenden Felder aktivieren. So ist es z.B. sinnvoll, keine Beiträge ohne Titel oder Text zu veröffentlichen. Im Falle fehlender Angaben fragt BlogDesk nach, und Sie können dann entweder die Angaben nachtragen oder den Beitrag dennoch veröffentlichen.

Zeitzone automatisch anpassen

Wenn Sie den Timestamp eines Beitrages anpassen, muss BlogDesk dem Blog-System mitteilen, wann denn nun der Beitrag erscheinen soll. Diese Option sorgt dafür, dass BlogDesk dabei die Zeitzone und deren Besonderheiten (z.B. Sommerzeit) beachtet. Laufen die Uhren Ihres Rechners und des Blog-Systems dann immer noch nicht synchron, können Sie eine Zusätzliche Verschiebung festlegen (z.B. 30 oder -60 Minuten).

Register Archivieren

In diesem Register legen Sie fest, ob und wie publizierte Beiträge anschließend auf Ihrem Rechner archiviert werden.

Beiträge nach dem Veröffentlichen Archivieren

Aktivieren Sie diese Option, wenn Beiträge nach dem Veröffentlichen archiviert werden sollen. Im Falle einer Archvierung wird der Beitrag als einzelne Datei im Unterverzeichnis Sent des Anwenderverzeichnisses abgelegt.

Beim Archivieren ein gesondertes Verzeichnis verwenden

Bei mehreren Blogs kann es sinnvoll sein, Beiträge eines Blogs in einem gesonderten Verzeichnis zu archivieren. Wenn Sie Standard erstellen wählen, wird im Verzeichnis Sent ein Unterverzeichnis mit dem Namen des Blogs erstellt. Über Auswählen können Sie auch ein beliebiges anderes Verzeichnis festlegen.


DirectUpload konfigurieren

DirectUpload konfigurieren

In der Regel brauchen Sie hier gar keine Angaben machen. Allerdings sollten Sie unbedingt einmal den Test ausführen, damit BlogDesk anhand der Ergebnisse die Einstellungen automatisch konfigurieren kann.

Zielverzeichnis

Beim DirectUpload gibt das Blog-System i.d.R. das Zielverzeichnis vor. Tragen Sie hier nur dann etwas ein, wenn Sie die Dateien in einem anderen Verzeichnis speichern wollen.

URL-Präfix

Normalerweise gibt das Blog-System nach erfolgreicher Übertragung den kompletten Dateinamen zurück, den BlogDesk dann innerhalb des Beitrages einsetzen kann. Ist der Dateiname (bzw. der URL) nicht komplett und kommt es deshalb zu Problemen, können Sie hier ein Präfix eintragen, der den Dateinamen dann jeweils vorangestellt wird. Ob ein solches Präfix nötig ist und wie es lauten sollte, darum kümmert sich BlogDesk automatisch, wenn Sie den Test ausführen.

Timestamp

Manche Blog-Systeme verwenden ohne weitere Kontrolle den Namen der übertragenen Datei. Existiert im Zielverzeichnis bereits eine Datei mit diesem Namen, wird sie ohne Rückfrage überschrieben. Durch das Anhängen eines Timestamps lässt sich eine solche Namenskollision so gut wie ausschließen. Wenn Sie den Test ausführen, prüft BlogDesk, ob diese Option aktiviert werden sollte.

Test

Wenn Sie den Test starten, wird BlogDesk ein kleines Bild auf den Server übertragen und von dort wieder zurück. Erscheint es anschließend in dem Feld darunter, sind alle Angaben korrekt. Die Einstellungen für URL-Präfix und Timestamp werden während des Testes automatisch angepasst.


FTP konfigurieren

FTP konfigurieren

Wenn Sie über einen FTP-Zugang auf Ihr Blog verfügen (oder über einen externen FTP-Server), dann können Sie diesen nutzen, um Bilder und Dateien zu übertragen. Die hier zu machenden Angaben entstprechen also den Angaben, die Sie auch in Ihrem FTP-Programm gemacht haben. Hier ein Beispiel:

blogdesk-blog-config-example-2

Host

Hier ist der Hostname des FTP-Servers ohne weitere Zusätze anzugeben.

Beispiele:

meinftpserver.de

ftp.meinserver.com

Port

Das hängt vom Server ab, der Standardwert ist 21.

Timeout

Legt fest, wieviele Sekunden BlogDesk auf eine Anwort des Servers wartet, bevor ein Fehler angenommen wird.

Login

Tragen Sie hier den Login (Benutzernamen) ein, den Sie auch verwenden, wenn Sie sich über Ihr FTP-Programm in den zum Blog gehörenden FTP-Account einloggen.

Passwort

Tragen Sie hier das Passwort ein, das Sie auch verwenden, wenn Sie sich über Ihr FTP-Programm in den zum Blog gehörenden FTP-Account einloggen.

Account

Dieses Feld kann in der Regel leer bleiben.

Upload-Verzeichnis

Das Upload-Verzeichnis ist das Verzeichnis auf dem Server, in dem die übertragenen Dateien gespeichert werden sollen. Wenn die Bilder später angezeigt werden, sucht das Blog-System in diesem Verzeichnis nach den betreffenden Dateien. Auch wenn es sich nur um ein Verzeichnis handelt, so haben doch der FTP-Server und das Blog-System einen eigenen 'Blick' auf dieses Verzeichnis. Das macht die Konfiguration etwas schwierig.

FTP

Hier ist der Name des Upload-Verzeichnisses auf dem FTP-Server anzugeben (relativ zum Host).

Beispiele:

/user/meinblog/wp-content/

/html/blogs/meinblog/wp-content/images/

Am einfachsten ermitteln Sie den Verzeichnisnamen, indem Sie sich mit Ihrem FTP-Programm einloggen und in das zum Blog gehörende Verzeichnis wechseln (das Sie bei der Installation des Blogsystems erstellt bzw. gewählt haben). Bei einem WordPress-Blog wird sich dort bereits das Unterverzeichnis wp-content befinden, in dem Sie zur Übersichtlichkeit evtl. noch ein weiteres Unterverzeichnis images erstellt haben. Wenn Sie in dieses Verzeichnis wechseln, wird Ihr FTP-Programm an geeigneter Stelle den kompletten Verzeichnisnamen anzeigen, den Sie nur noch übernehmen müssen.

Wenn Ihr Blog bei einem Bloghoster wie blogg.de liegt, haben Sie in der Regel keinen Zugriff auf den FTP-Server. Sie können Ihre Bilder aber auch auf einen externen FTP-Server übertragen. Oder Sie verwenden den DirectUpload.

Blog

Auch hier ist das Upload-Verzeichnis anzugeben, diesmal allerdings relativ zum Blog-Host.

Beispiele:

/wp-content/

/wp-content/images/

Der Name dieses Verzeichnisses ergibt entspricht dem unter FTP eingegebenen Namen, ist aber in der Regel nicht identisch. Da das Blogsystem nur einen eingeschränkten 'Blick' auf die FTP-Verzeichnisse hat, gleicht sich in der Regel nur der hintere Teil des Namens. So könnte das FTP-Verzeichnis

/html/blogs/meinblog/wp-content/images/

für das Blogsystem

/wp-content/images/

lauten, und dieser Name ist dann hier einzutragen.

Falls Sie Ihre Bilder auf einen völlig anderen und vom Blogsystem unabhängigen FTP-Server übertragen, ist der komplette Web-Verzeichnisname anzugeben, in dem das Blogsystem die Bilder finden kann. Wenn Sie z.B. bei Lycos einen FTP-Account haben und dorthin Ihre Bilder übertragen, dann könnte das Bilder-Verzeichnis so aussehen:

Beispiel:

http://mitglied.lycos.de/kundename/

Verbindung

Hier können Sie den Typ der Verbindung festlegen. Bei einer sicheren Verbindung ist in der Regel auch der Port anzupassen (Standardwert ist dann 990).

Die Option Passiver Modus ist evtl. zu aktivieren, falls Sie sich hinter einer Firewall befinden und es beim Verbinden mit dem Server zu Problemen kommt.

Test

In diesem Feld können Sie die Angaben für den FTP-Zugang und die Verzeichnisse testen.


Beitrag erstellen & bearbeiten

Neuen Beitrag erstellen

Sie haben folgende Möglichkeiten, einen neuen Beitrag zu erstellen:
1. Über den Befehl Neu im Menü Datei.
2. Über den Befehl Neu mit Vorlage im Menü Datei, wobei Sie eine Vorlage auswählen können, auf deren Basis der Beitrag dann erstellt wird.
3. Über den ersten Button auf der Buttonleiste ( [image] ). Drücken Sie dabei auf den kleinen Pfeil, können Sie eine Vorlage auswählen.

Wurde beim Erstellen keine Vorlage ausgewählt, verwendet BlogDesk die in den Optionen festgelegten Standardoptionen für neue Beiträge.

Beiträge speichern und öffnen

Beiträge können über den Befehl Speichern im Menü Datei bzw. den entsprechenden Button auf der Buttonleiste ( [image] ) jederzeit gespeichert werden. Das ist z.B. sinnvoll, wenn Sie die Arbeit vor dem Publizieren unterbrechen oder sichern wollen. Standardmäßig speichert BlogDesk den aktuellen Beitrag automatisch alle 5 Minuten. Diese Funktion können Sie in den Optionen deaktivieren.

Standardmäßig verwendet BlogDesk den Titel des Beitrages als Vorgabe für den Dateinamen, im Normalfall müssen Sie den Dateinamen also nicht extra noch eingeben. Diese SmartSave-Funktion können Sie in den Optionen deaktivieren.

Über den Befehl Öffnen im Menü Datei bzw. den zweiten Button auf der Buttonleiste ( [image] ) können Sie einen vorher gespeicherten Beitrag wieder öffnen und weiter bearbeiten. Neben diesen noch unveröffentlichten Beiträgen gibt es im Öffnen-Dialog auch ein Register für Vorlagen und Veröffentlichte Beiträge. Wenn Sie einen bereits veröffentlichten Beitrag öffnen, ist dieser zunächst schreibgeschützt und kann nicht verändert werden. Sobald Sie ihn aber erneut speichern, erstellt BlogDesk eine neue Kopie dieses Beitrages und Sie können ihn beliebig verändern und erneut veröffentlichen.

Beiträge bearbeiten

Grundsätzlich können Sie sofort nach dem Erstellen eines Beitrages einen Titel eingeben, im großen Feld darunter Ihren Text schreiben und den Beitrag schließlich publizieren. Um alle weiteren Möglichkeiten und Optionen brauchen Sie sich nur bei Bedarf kümmern.

Beachten Sie, dass nicht alle Optionen und Möglichkeiten auch von allen Blogsystemen und Bloghostern unterstützt werden. Im Zweifelsfall müssen Sie das ausprobieren.

Ansicht

BlogDesk bietet zwei Modi für das Bearbeiten des Textes, zwischen denen man im Menü Ansicht (oder über die Funktionstaste F5) umherschalten kann. Der aktuelle Modus wird unten links auf der Statuszeile angezeigt.

Die meisten Anwender werden den Editor in der WYSIWYG-Ansicht (Normal) bevorzugen: der Text lässt sich wie in einer normalen Textverabeitung formatieren, man sieht sofort das Ergebnis und muss nicht mit komplizierten HTML-Tags jonglieren.

Natürlich kann man bei Bedarf auch auf den HTML-Code (Source) zugreifen, dort vorgenommene Änderungen werden dann in die normale Ansicht übernommen.

Die dritte Ansicht (Preview) entspricht weitestgehend der normalen Ansicht, allerdings kann man den Text hier nicht mehr verändern. Außerdem wird beim Klick auf einen Link die betreffende Seite im Standardbrowser geöffnet.

Formatierungen

Über das Menü Format und die korrespondierenden Buttons auf der Buttonleiste lassen sich die gängigen Formatierungen vornehmen, z.B. für fette oder kursive oder farbliche Hervorhebungen. Wichtig sind auch der Einzug (für Zitate) und die Listen für Aufzählungen. In jedem Fall gilt: gehen Sie im Interesse Ihrer Leser sehr sparsam mit Formatierungen um.

Wie diese Elemente später innerhalb des Blogs aussehen, hängt natürlich von dessen Format-Definitionen ab. Um diese möglichst genau in BlogDesk abzubilden, können Sie die zugrunde liegende CSS-Datei bearbeiten.

Bilder einfügen

Einer der großen Vorteile von BlogDesk gegenüber dem herkömmlichen Erstellen von Beiträgen ist die komfortable Möglichkeit, Bilder in den Text zu integrieren. Über den Befehl Bild einfügen im Menü Bearbeiten bzw. den entsprechenden Button auf der Buttonleiste ( [image] ) haben Sie folgende Möglichkeiten:

Datei auswählen

Wählen Sie diesen Befehl, wenn Sie ein Bild verwenden wollen, das sich bereits auf Ihrer Festplatte befindet. Nach der Auswahl der gewünschten Datei öffnet sich der ImageWizard, wo Sie das Bild noch weiter bearbeiten können (zuschneiden, Größe ändern etc.).

Aus der Zwischenablage

Auch mit diesem Befehl öffnen Sie den ImageWizard, übernehmen dabei allerdings das aktuell in der Windows-Zwischenablage befindliche Bild. Das ist sehr praktisch, wenn Sie vorher über die Druck-Taste einen Screenshot erstellt haben (z.B. von der gerade in Ihrem Browser angezeigten Webseite).

Externer Link

Manchmal will man Bilder verwenden, die sich bereits auf einem anderen Server befinden. Wählen Sie diesen Befehl, so erscheint ein Fenster, in dem Sie die komplette Adresse des Bildes (also z.B. http://meinbilderserver.de/bild.gif) eingeben müssen. Der Editor wird daraufhin versuchen, das Bild für die Anzeige aus dem Internet zu laden. Gelingt dies nicht, wird lediglich ein Platzhalter angezeigt. In jedem Fall handelt es sich aber um einen Verweis auf das ursprüngliche Bild, auch nach der Veröffentlichung des Beitrages. Verschwindet dieses Bild eines Tages oder wird es verändert, so hat das natürlich entsprechende Auswirkungen auf Ihren Beitrag.

Links einfügen

Auch Links lassen sich komfortabel in einem Fenster eingeben, das sich über den Befehl Link einfügen im Menü Bearbeiten bzw. den entsprechenden Button auf der Buttonleiste ( [image] ) öffnen lässt.

Alternativ dazu lassen sich Links auch direkt aus der Zwischenablage einfügen (über Bearbeiten/Einfügen), wobei der Editor selbständig das passende Protokoll erkennt (z.B. http oder mailto bei E-Mail-Adressen).

Wenn Sie innerhalb des Editors mit dem Mauszeiger auf einen Link zeigen, wird der dazugehörige URL unten auf der Statuszeile angezeigt. Bei einem Doppelklick auf den Link öffnet sich wieder das Fenster zum Bearbeiten.

Möglich ist nicht nur das Verweisen auf externe Seiten, sondern auch auf lokale Dateien (z.B. eine PDF-Datei oder ein MP3). Wählen Sie dafür Link einfügen und drücken Sie dann Datei. Wenn Sie auf diese Weise lokale Dateien verlinken, werden diese beim Veröffentlichen des Beitrages automatisch mit auf den Server übertragen. Leser Ihres Beitrages müssen diesen Link dann nur anklicken, um die betreffende Datei auf ihren eigenen Rechner zu laden.

SmartUpload einfügen

Diese spezielle Funktion erleichtert die Zusammenarbeit mit Media-Plugins, wie sie zB. für WordPress existieren. Wollen Sie zB. in einem Beitrag eine MP3-Datei über einen Flash-Player zum Anhören anbieten, dann müssten Sie eigentlich recht umfangreichen HTML-Code dafür schreiben. Ein entsprechendes Media-Plugin nimmt Ihnen diese Arbeit ab. Allerdings braucht dieses Plugin den Namen der abzuspielenden MP3-Datei und natürlich muss diese Datei vorher noch auf den Server übertragen werden. Und genau dabei hilft der SmartUpload.

Wenn Sie einen SmartUpload einfügen (über den entprechenden Befehl im Menü Bearbeiten) wollen, müssen Sie lediglich die gewünschte Datei auswählen, die später auf den Server übertragen werden soll. Innerhalb des Textes fügt BlogDesk dann den Platzhalter {SmartUpload} ein. Dieser Platzhalter wird nach dem Upload der verbundenen Datei durch den sich dabei ergebenden Dateinamen auf dem Server ersetzt.

Beispiel: Manche Plugins kümmern sich um die Anzeige von Flash-Filmen und brauchen dafür lediglich den Namen der Datei in eckigen Klammern. In diesem Fall müssten Sie die entsprechende FLV-Datei als SmartUpload in den Beitrag einfügen und den Platzhalter in eckige Klammern setzen. Aus

[{SmartUpload}]

wird dann nach dem Upload zB.

[http://www.meinblog.de/files/film.flv]

also genau das, was das Media-Plugin für die weitere Arbeit braucht.

HTML einfügen

Über den Befehl HTML einfügen im Menü Bearbeiten bzw. den entsprechenden Button auf der Buttonleiste ( [image] ) können Sie gültigen HTML Code an der aktuellen Cursorposition in Ihren Beitrag einfügen. Das ist z.B. praktisch, wenn Sie umfangreichen Code zum Einbinden eines YouTube-Videos oder anderer Multimedia-Sites einfügen wollen.

Optionen

Neben Titel und Text gibt es auf der rechten Seite der Programmoberfläche noch einige Optionen, die den Optionen innerhalb des Administrationsbereiches des Blogsystems entsprechen. Welche Optionen standardmäßig für einen neuen Beitrag aktiviert sind, hängt von den Standardvorgaben ab bzw. von der zugrunde liegenden Vorlage.

Blogs und Kategorien

In dieser Liste werden alle Blogs und deren Kategorien aufgelistet. Hier können Sie also angeben, in welchem Blog der Beitrag erscheinen (möglich sind durchaus auch mehrere Blogs gleichzeitig) und welchen Kategorien er zugeordnet werden soll.

Kommentare erlauben

Legt fest, ob der Beitrag von den Lesern kommentiert werden darf.

Pings erlauben

Legt fest, ob Pings/Trackbacks für diesen Beitrag zugelassen sind.

Beitrag nach der Übertragung publizieren

Legt fest, ob der Beitrag nach der Übertragung auf den Server publiziert werden soll. Ist diese Option aktiviert, erscheint der Beitrag sofort innerhalb des Blogs. Ist die Option deaktiviert, veröffentlicht das Blogsystem diesen Beitrag vorerst nicht, sondern legt ihn als Entwurf bzw. Draft ab. Endgültig publizieren lässt er sich dann nur noch innerhalb des Administrationsbereiches des Blogsystems.

Datum & Zeit vorgeben

Standardmäßig erhält ein Beitrag nach der Übertragung vom Blogsystem den aktuellen Zeitstempel. Aktivieren Sie hingegen diese Option, können Sie anschließend ein anderes Datum/Zeit vorgeben. Wenn Sie zB. ein früheres Datum eingeben, erscheint der Beitrag tatsächlich an der chronologisch passenden Stelle im Archiv des Blogs (und evtl. gar nicht mehr auf der aktuellen Frontseite). Geben Sie hingegen ein Datum in der Zukunft ein (Post to future), wartet das Blogsystem mit der Veröffentlichung bis zu dem gewünschten Zeitpunkt.

In den Blog-Eigenschaften können Sie festlegen, ob BlogDesk den Zeitstempel an die Zeitzone anpassen soll. Außerdem lässt sich noch eine zusätzliche Verschiebung festlegen.

(Hinweis: Nicht alle Blog-Systeme unterstützen diese Funktion zuverlässig, auch WordPress hat damit noch Probleme. Diese werden hoffentlich in einer zukünftigen Version gelöst.)

Trackbacks

In diesem Feld können Sie Trackbacks eingeben. Mehrere Links sind durch Kommas oder Absätze zu trennen.

Sektionen

Wer innerhalb von WordPress einen längeren Beitrag in Intro und Text aufteilen will, muss diese beiden Sektionen mit dem HTML-Tag <!--more--> trennen. Dadurch wird auf der Frontseite des Blogs nur das Intro angezeigt, ein Link (Weiterlesen) führt dann zum Rest des Artikels. Für diese beiden Sektionen gibt es in BlogDesk getrennte Textfelder, zwischen denen Sie mittels der Schaltflächen Beitrag und Mehr umherschalten können.

Und es gibt noch eine dritte Sektion: Zusammenfassung. Die Zusammenfassung eines Textes wird in der Regel bei der Archiv-Anzeige und innerhalb von RSS-Feeds verwendet. Normalerweise werden dafür einfach die ersten 120 Zeichen des Beitrages genommen. Wenn Sie den Inhalt der Zusammenfassung jedoch vorgeben wollen (z.B. um die Qualitiät des RSS-Feeds zu erhöhen), können Sie das in diesem Feld.

Sobald eine Sektion Text enthält, wird die dazugehörige Schaltfläche mit schwarzer Schrift dargestellt. So erkennen Sie jederzeit, wo Sie bereits Text eingegeben haben.


Bilder mit dem ImageWizard bearbeiten

Bilder mit dem ImageWizard bearbeiten

Mit dem ImageWizard lassen sich Bilder nicht nur in einen Beitrag einfügen, sondern auch noch bearbeiten und anpassen.

Bilder auswählen

Über den Befehl Bild einfügen im Menü Bearbeiten bzw. den enstpechenden Button ( [image] ) können Sie entweder eine bestimme Datei auswählen oder den Inhalt Aus der Zwischenablage übernehmen. Daraufhin erscheint der ImageWizard mit dem gewählten Bild, das Sie entweder direkt übernehmen oder noch bearbeiten können. Öffnen lässt sich der ImageWizard auch im Nachhinein, indem Sie ein bereits eingefügtes Bild doppelt anklicken oder markieren und den Befehl Bild bearbeiten ausführen.

Wenn Sie ein bereits vorhandenes Bild einfügen, kopiert BlogDesk automatisch eine Kopie davon in das Verzeichnis Images unterhalb des Programmverzeichnisses. Etwaige Änderungen am Bild haben also keinerlei Auswirkungen auf das Original.

Bilder bearbeiten

Über die Sektionen am rechten Rand des ImageWizards lässt sich das Bild bearbeiten. Wenn Sie den Titel einer solchen Sektion anklicken, erscheinen die jeweiligen Optionen und Werkzeuge.

Zwischen den einzelnen Optionen einer Sektion (z.B. Winkel beim Drehen) können Sie beliebig wechseln. Die Änderung wird erst dann übernommen, wenn Sie eine andere Sektion aktivieren oder den ImageWizard verlassen.

Über den Befehl Alle Änderungen verwerfen wird wieder der Originalzustand hergestellt. Und über den Befehl Neues Bild öffnen können Sie eine ganz neue Datei auswählen.

Größe anpassen

Die richtige Größe eines Bildes ist sehr wichtig, weil zu breite Bilder das Layout des Blogs sprengen können. Aus diesem Grund zeigt der ImageWizard eine Warnmeldung an, wenn das Bild zu breit für das Blog ist.

Die tatsächliche Breite des Blogs können Sie über den Schalter Breite des Blogs einstellen bzw. bearbeiten. Evtl. müssen Sie vorher das Layout Ihres Blogs untersuchen, um die genaue Breite (in Pixel) zu ermitteln. Die Standardbreite von 450 Pixel entspricht der Breite des unter WordPress häufig verwendeten Theme Kubrick.

Die Breite des Bildes können Sie nun in drei Stufen (Groß, Mittel, Klein) oder ganz Frei einstellen. Innerhalb des Textfeldes können Sie die gewünschte Breite entweder direkt eingeben oder mit Pfeil-Hoch und Pfeil-Runter schrittweise verstellen.

Über den Befehl Thumbnail erstellen lässt sich ein sog. Vorschaubild erstellen. Das lohnt sich vor allem bei sehr großen Bildern, die man innerhalb des Blogs nur mit einer Vorschau zeigen will. Klickt der Leser dann auf diese Vorschau, wird das große Bild angezeigt. Das Vorschaubild wird zunächst auf die maximal erlaubte Breite gebracht (also auf die Breite des Blogs) und kann anschließend noch weiter bearbeitet werden. Im Grunde haben Sie anschließend zwei miteinander verknüpfte Bilder, um die Sie sich aber nicht weiter kümmern müssen, da BlogDesk das Verlinken und Übertragen auf den Server automatisch erledigt.

Zuschneiden

Häufig lohnt es sich, nur einen bestimmten Bereich des Bildes zu übernehmen. Mit gedrückter linker Maustaste lässt sich dafür innerhalb des Bildes eine Markierung aufspannen, deren Ränder sich anschließend noch verschieben lassen. Sobald Sie Übernehmen drücken, wird der festgelegte Bereich ausgeschnitten.

Bei sehr kleinen oder großen Bildern ist das Zuschneiden nicht leicht möglich. Für diesen Fall gibt es die Option Ansicht auf Fenstergröße, mit der das Bild für den Zuschneidevorgang auf die Breite des Fensters gebracht wird. Nach dem Zuschneiden wird das Bild dann wieder in seiner tatsächlichen Größe dargestellt.

Drehen & Spiegeln

Das Bild kann in festen Winkeln oder völlig frei gedreht werden. Innerhalb des Textfeldes können Sie den gewünschten Winkel entweder direkt eingeben oder mit Pfeil-Hoch und Pfeil-Runter schrittweise verstellen.

Über die beiden Befehle Horizontal spiegeln und Vertikal spiegeln lässt sich das Bild spiegeln.

Schatten & Ränder

In dieser Sektion lassen sich dem Bild Schatten und Ränder zuweisen.

Farben

Hier lässt sich bei Bedarf die Farbtiefe des Bildes anpassen. Die Hingergrundfarbe sollten Sie anpassen, falls auch Ihr Blog eine andere Hintergrundfarbe als Weiß hat. Wichtig wird diese Einstellung z.B. bei Transparenz oder beim Drehen, wenn freie Bereiche mit der Hintergrundfarbe gefüllt werden.

Ausrichtung im Text

Diese Einstellung hat keine Auswirkung auf die Darstellung des Bildes innerhalb des ImageWizards, sondern wird erst innerhalb des Beitrages zusammen mit dem Text sichtbar. Es geht dabei um die Ausrichtung des Bildes zwischen dem Text bzw. neben dem Text sowie den Abstand zum Text.

Wenn Sie das Bild rechts oder links neben dem Text ausrichten, müssen Sie darauf achten, dass es auch genügend Text gibt, um diesen Bereich zu füllen. Ansonsten kann es evtl. zu unvorhergesehener Darstellung innerhalb des Blog-Systems kommen, wenn nämlich Text aus nachfolgenden Beiträgen nach oben gezogen wird, um den Bereich neben dem Bild aufzufüllen.

Format

Das Datei-Format des Bildes wird zunächst durch das Format des Originals vorgegeben, kann aber in der Liste Format auch geändert werden. Z.B. sollten Sie ein BMP-Bild besser in GIF oder JPG umwandeln, da es so weniger Speicherplatz verbraucht. Zu beachten ist auch, dass die meisten Browser zwar WBMP darstellen können, nicht aber der BlogDesk-Editor (dort erscheint nur ein Platzhalter).


Beitrag publizieren

Beitrag publizieren

Beim Publizieren wird der in BlogDesk erstellte Beitrag (evtl. zusammen mit darin verwendeten Bildern) auf den Server übertragen und in das Blogsystem integriert. Für diesen Vorgang muss der Rechner online sein. Folgendermaßen lässt sich die Übertragung starten:
1. Über den Befehl Beitrag veröffentlichen im Menü Datei
2. Über den vierten Schalter auf der Buttonleiste ( [image] )

Um versehentliches Publizieren eines Beitrages zu verhindern, fragt BlogDesk standarmäßig vor der Übertragung noch einmal nach. Diese Frage können Sie in den Optionen deaktivieren. Dort können Sie auch festlegen, ob vor dem Veröffentlichen automatisch eine Rechtschreibprü fung durchgeführt werden soll.

Wenn Sie sicherstellen wollen, dass vor der Übertragung bestimmte wichtige Felder ausgefüllt sind, können Sie dies in den Blog-Eigenschaften festlegen.

Was nach der Übertragung innerhalb des Blogsystems mit dem Beitrag passiert, hängt von der Option Beitrag nach der Übertragung publizieren ab. Ist diese Option aktiviert, erscheint der Beitrag sofort innerhalb des Blogs (falls Sie nicht den Timestamp verändert haben). Ist die Option deaktiviert, veröffentlicht das Blogsystem diesen Beitrag vorerst nicht, sondern legt ihn als Entwurf bzw. Draft ab. Endgültig publizieren lässt er sich dann nur noch innerhalb des Administrationsbereiches des Blogsystems.

Nach dem erfolgreichen Übertragen wird der Beitrag geschlossen und in dem dafür vorgesehen Verzeichnis Ihrer Festplatte archiviert. Ob und wo diese Archivierung stattfindet, können Sie in den Blog-Eigenschaften festlegen.


Bereits veröffentlichte Beiträge bearbeiten

Veröffentlichte Beiträge bearbeiten

Bereits veröffentlichte Beiträge lassen sich nachträglich noch bearbeiten. Das ist praktisch, wenn Sie Fehler im Beitrag entdecken oder Informationen nachliefern wollen. Manche Blog-Systemen bzw. Blog-Hostern unterstützen diese Funktion allerdings nicht oder nur eingeschränkt, im Zweifelsfall müssen Sie das einfach ausprobieren.

Gehen Sie folgendermaßen vor, wenn Sie einen bereits veröffentlichten Beitrag bearbeiten wollen:
1. Wählen Sie Beiträge nachträglich bearbeiten im Menü Datei.
2. Lassen Sie sich die zuletzt veröffentlichten Beiträge anzeigen. Legen Sie dafür die Zahl der anzuzeigenden Beiträge (bis zu 999) und das Blog fest und drücken Sie Anzeigen.
3. Wählen Sie den gewünschten Beitrag und drücken Sie Bearbeiten.

BlogDesk lädt daraufhin den Beitrag vom Server und zeigt ihn an. Ob dabei auch alle ursprünglichen Kategorien und Optionen übernommen wurden, hängt davon ab, wie gut das Blog-System diese Funktion implementiert.

Enthält der Beitrag Bilder, so wird direkt auf den Server verlinkt. Beim erneuten Veröffentlichen müssen die Bilder also nicht noch einmal übertragen werden, da sie sich ja bereits dort befinden. Allerdings können Sie derart verlinkte Bilder nicht mehr lokal mit dem ImageWizard bearbeiten. Falls Sie auch die Bilder anpassen wollen, müssen Sie diese wieder lokal einfügen.

Beachten Sie auch, dass für den Beitrag zunächst das originale Veröffentlichungsdatum gesetzt ist (Zeitstempel). Damit wird erreicht, dass der bearbeitete Beitrag anschließend im Blog an seiner ursprünglichen Position erscheint. Natürlich können Sie das Datum auch anpassen.

Wenn Sie alle gewünschten Änderungen vorgenommen haben, müssen Sie den überarbeiteten Beitrag nur noch veröffentlichen. BlogDesk fragt dann extra noch mal nach, ob der bisheriger Beitrag durch die neue Version ersetzt werden soll.

Veröffentlichte Beiträge löschen

Sie können einen bereits veröffentlichten Beitrag nicht nur nachträglich bearbeiten, sondern auch gleich ganz vom Server löschen. Auch diese Funktion wird von manchen Blog-Systemen bzw. Blog-Hostern nicht oder nur eingeschränkt unterstützt.

Gehen Sie folgendermaßen vor, wenn Sie einen bereits veröffentlichten Beitrag löschen wollen:
1. Wählen Sie Beiträge nachträglich bearbeiten im Menü Datei.
2. Lassen Sie sich die zuletzt veröffentlichten Beiträge anzeigen. Legen Sie dafür die Zahl der anzuzeigenden Beiträge und das Blog fest und drücken Sie Anzeigen.
3. Wählen Sie den gewünschten Beitrag und drücken Sie Löschen.

Beiträge erneut veröffentlichen

Wenn Sie einen bereits veröffentlichten Beitrag erneut veröffentlichen wollen (z.B. in einem anderen Blog), ohne dabei das Original zu verändern, brauchen Sie diesen Beitrag vorher nicht extra vom Server laden. Standardmäßig archiviert BlogDesk nämlich alle von Ihnen veröffentlichten Beiträge. Einen solchen Beitrag können Sie später wieder öffnen und erneut publizieren. Gehen Sie folgendermaßen vor:
1. Wählen Sie Öffnen im Menü Datei.
2. Wechseln Sie ins Regiser Veröffentlichte Beiträge.
3. Standardmäßig werden Beiträge im Ordner Sent archiviert. Falls Sie aber für das betreffende Blog ein anderes Archiv-Verzeichnis festgelegt haben, müssen Sie dies hier einstellen.
4. Wählen Sie den gewünschten Beitrag und bestätigen Sie mit OK.

Ein derart geöffneter Beitrag kann zunächst weder verändert noch veröffentlicht werden. Sobald Sie ihn aber ein erstes Mal speichern, erstellt BlogDesk eine Kopie des Beitrages, die dann verändert und schließlicht erneut publiziert werden kann.


Notizblock, Textbausteine und Technorati-Tags-Generator

Notizblock

Im Notizblock können Sie Text zwischenspeichern und bei Bedarf umstellen, bevor Sie ihn dann in den eigentlichen Beitrag einfügen oder für andere Zwecke weiterverwenden. Um die Übersicht zu behalten, lassen sich mehrere Kategorien erstellen, zwischen denen Sie in der Liste auf der rechten Seite wechseln können.

Öffnen lässt sich der Notizblock über den entsprechenden Befehl im Menü Extras. Wenn Sie das Notizblock-Fenster schließen, wird der enthaltene Text automatisch gespeichert. Beim nächsten Aufruf sind Sie wieder dort, wo Sie es geschlossen haben. Die klassische Prozedur von Öffnen und Speichern entfällt also.

Textbausteine

Textbausteine sind sehr praktisch, wenn Sie häufig bestimmte Formeln, Phrasen oder Sätze verwenden. Diese lassen sich dann einfach einfügen, statt sie jedesmal neu eintippen zu müssen. Öffnen lassen sich die Textbausteine über den entsprechenden Befehl im Menü Extras.

Viele Blogger verwenden z.B. Hinweise wie Via Blog Soundso (incl. Link), falls sie durch das Blog Soundso auf Inhalte aufmerksam gemacht wurden, über die sie nun in ihrem eigenen Blog berichten. Für häufig zitierte Blogs lohnt es sich dann, einen entsprechenden Textbaustein zu erstellen.

Auch die gerne in Blogs verwendeten Akronym-Definitionen lassen sich prima als Textbaustein definieren und bei Bedarf einfügen. Beispiel:

<acronym title="Cascading Style Sheets">CSS</acronym>

Die Textbausteine lassen sich in Gruppen ordnen. Über den Schalter Bearbeiten können Sie Gruppen und Textbausteine erstellen, bearbeiten und wieder löschen. Mittels Drag & Drop lassen sich Textbausteine von einer Gruppe in eine andere verschieben.

Ein Textbaustein besteht aus Titel (der innerhalb der Liste angezeigt wird) und Text (der auch HTML-Code enthalten kann). Geben Sie keinen Titel an, übernimmt BlogDesk automatisch den ersten Absatz des Textes. Beim Einfügen wird der Text an der aktuellen Cursorposition in den Beitrag eingefügt.

Technorati-Tags-Generator

Viele Blogger verschlagworten ihre Beiträge mit Technorati-Tags. Das manuelle Einfügen solcher Tags ist recht aufwändig, da zu jedem Tag auch der entsprechende Link gehört (z.B. http://www.technorati.com/tags/blogdesk). Der Tags-Generator kümmert sich um diese Arbeit, Sie müssen nur noch die gewünschten Tags auswählen oder eingeben. Öffnen lässt sich der Tags-Generator über den entsprechenden Befehl im Menü Extras.

In der Liste Verfügbare Tags können Sie die gewünschten Tags markieren, sie erscheinen daraufhin im unteren Textfeld Ausgewählte Tags. Dort können Sie fehlende Tags nachtragen (jeweils durch Kommas getrennt), sie werden dann beim Schließen automatisch in die Liste übernommen. Die Liste aller Tags kann über den Schalter Liste auch direkt bearbeit werden.

Wenn Sie mit OK bestätigen, macht BlogDesk aus den gewählten Tags eine komplette Zeile und fügt diese an der aktuellen Cursorposition in den Beitrag. Wie diese Zeile formatiert wird, können Sie über den Schalter Format festlegen.


Optionen

Optionen

Über den Befehl Optionen im Menü Extras können Sie die Optionen aufrufen, die in mehrere Register unterteilt sind.

Neue Beiträge

In diesem Register können Sie die Standardoptionen für einen neuen Beitrag festlegen. Dabei handelt es sich nur um Vorgaben bei der Erstellung eines Beitrages, die natürlich auch geä ndert werden können.

Blog

Aktivieren Sie in dieser Liste das oder die Blogs, in denen ein neuer Beitrag standarmäßig veröffentlicht werden soll.

Kommentare erlauben

Legt fest, ob der Beitrag kommentiert werden darf.

Pings erlauben

Legt fest, ob Pings/Trackbacks für diesen Beitrag zugelassen sind.

Beitrag nach der Übertragung publizieren

Legt fest, ob der Beitrag nach der Übertragung auf den Server publiziert werden soll.

Vorlage

Wenn Sie bereits eine Vorlage gespeichert haben, kann diese hier als Grundlage für alle neuen Beiträge festgelegt werden. Die Einstellungen der Vorlage haben dann Vorrang vor den Standardoptionen.

Editor

In diesem Register finden Sie Optionen, die den Editor betreffen.

Schrift im Source-Editor

Legen Sie hier die Schrift fest, die beim Bearbeiten eines Beitrages im Source-Modus verwendet werden soll.

Paragraph-Tags (<p> und <br>) anzeigen

Für bessere Übersichtlichkeit lassen sich innerhalb des Source-Editors die Tags für Absätze durch diese Option ausblenden. Das betrifft allerdings nur die Anzeige im Editor. Wenn die betreffenden Tags beim Veröffentlichen tatsächlich aus dem Beitrag entfernt werden sollen (weil das in manchen Blog-Systemen zu besseren Ergebnissen führt), ist dafür die entsprechende Option in den Blog-Eigenschaften zu aktivieren.

Rechtschreibprüfung

Die Angaben in diesem Register betreffen die Rechtschreibprüfung.

Wörter in GROSSBUCHSTABEN ignorieren

Sorgt dafür, dass Wörter, die nur aus Großbuchstaben bestehen, bei der Prüfung ignoriert werden.

Zahlen ignorieren

Sorgt dafür, dass Zahlen ignoriert werden.

Wörter mit Zahlen ignorieren

Sorgt dafür, dass Wörter ignoriert werden, die Zahlen enthalten.

Vor dem Veröffentlichen automatisch prüfen

Startet (auf Nachfrage) die Rechtschreibprüfung, bevor ein Beitrag endgültig veröffentlicht wird.

Wörterbücher - Standard

In dieser Liste werden die verfügbaren Standard-Wörterbücher aufgelistet. Aktivieren Sie hier die Wörterbücher, die bei der Rechtschreibprüfung beachtet werden sollen. Wenn Sie mehrere Wörterbücher aktivieren, verlangsamt das natürlich die Kontrolle.

Wörterbücher - Benutzer

Während der Rechtschreibprüfung können Sie unbekannte Wörter in ein Wörterbuch aufnehmen. Hier können Sie die dabei zu verwendenden Wörterbücher aktivieren und auch neue erstellen oder löschen.

Extras

SmartSave

Wie in jedem normalen Progamm lässt sich die Arbeit an einem Beitrag jederzeit speichern. Da Sie für einen Beitrag in der Regel bereits einen Titel eingegeben haben, würde es nur unnötig Mühe machen, beim Speichern dann zusätzlich noch einen Dateinamen einzugeben. Ist die Option SmartSave aktiv, ermittelt BlogDesk selbständig anhand des Titels einen Dateinamen.

Automatisch speichern alle x Minuten

Wenn diese Option aktiviert ist, speichert BlogDesk Beiträge automatisch im angegebenen Zeitintervall.

Vor dem Publizieren noch einmal nachfragen

Die Nachfrage vor dem Publizieren schützt Sie vor dem versehentlichen Abschicken noch unfertiger Beiträge.

ToolTipps anzeigen

Sorgt für die Anzeige einer kleinen Hilfe, sobald sich der Mauszeiger über einem der Buttons auf der Buttonleiste der Programmoberflä che befindet.

Im SystemTray anzeigen

Sorgt dafür, dass BlogDesk im System Tray (rechts unten neben der Uhr) angezeigt wird und dort im minimierten Zustand durch einen Klick wieder aktiviert werden kann.

Datei zum Speichern von Debug-Informationen

Geben Sie hier eine Datei an, in der beim Veröffentlichen eines Beitrages Debug-Informationen gespeichert werden sollen. Diese Informationen können bei der Fehlersuche helfen. BlogDesk speichert neue Informationen immer am Ende der Datei, die daher kontinuierlich anwächst und evtl. gelgentlich gelöscht werden sollte.

Sprache

Benutzeroberfläche

Für die Benutzeroberfläche (Menü, Dialoge etc.) stehen mehrere Sprachen zur Verfügung, zwischen denen Sie jederzeit wechseln können. Auf www.blogdesk.org finden Sie evtl. noch weitere Sprachen.

Hilfe

Die Hilfe erscheint, sobald Sie an beliebiger Stelle die F1-Taste drücken. Die gewünschte Sprache der Hilfe können Sie hier festlegen.


Vorlagen

Vorlagen

Vorlagen sind sehr praktisch, wenn man beim Erstellen mancher Beiträge bestimmte Optionen vorgeben will, statt sie jedes Mal neu auswählen zu müssen. Wenn Sie z.B. für manche Beiträge immer zwei feste Kategorien auswählen und zudem die Option Kommentare erlauben deaktivieren, dann können Sie das in einer Vorlage zusammenfassen.

Vorlagen erstellen

Vorlagen werden wie ganz normale Beiträge erstellt, sogar Titel und Text lassen sich vorgeben (obwohl das sicher nur in Spezialfällen sinnvoll ist). Wenn alle Optionen wie gewünscht eingestellt sind, müssen Sie nur noch den Befehl Als Vorlage speichern im Menü Datei aufrufen und der Vorlage einen passenden Namen geben.

Bereits erstellte Vorlagen lassen sich auch im Nachhinein bearbeiten. Wählen Sie Öffnen im Menü Datei, wechseln Sie ins Register Vorlagen und wählen Sie die gewünschte Vorlage.

Neuen Beitrag anhand einer Vorlage erstellen

Sie haben mehrere Möglichkeiten, beim Erstellen eines neuen Beitrages eine Vorlage zu verwenden:
1. Wählen Sie im Menü Datei den Befehl Neu mit Vorlage und wählen Sie im Untermenü die gewünschte Vorlage. Der Eintrag (Standard) entspricht dabei den Standardvorgaben, wie sie in den Optionen festgelegt sind.
2. Drücken Sie auf den kleinen Pfeil des Schalters Neu ( [image] ), dann erscheint ebenso das Menü mit den verfügbaren Vorlagen.
3. Wenn grundsätzlich alle Beiträge auf der Basis einer bestimmten Vorlage erstellt werden sollen, dann können Sie diese in den Optionen festlegen.

CSS- und HTML-Dateien anpassen (Master-Templates)

Bei den Master-Templates geht es nicht um Optionen, sondern um die Formatierungen eines Beitrages. Wie diese nämlich nach der Übertragung in Ihrem Blog aussehen, hängt von den dortigen Format-Definitionen ab. Diese ergeben sich aus dem verwendeten Theme und den zugrunde liegenden CSS-Dateien.

Wie nun bringt man BlogDesk dazu, sich zumindest an einige dieser Merkmale (z.B. Schriftart und -größe) zu halten? Dafür ist im Anwenderverzeichnis die Datei DEFAULT.CSS entsprechend anzupassen.

Sie können sogar noch weiter gehen und die den drei Sektionen zugrunde liegenden HTML-Dateien modifizieren. Diese Dateien liegen im Unterverzeichnis Template und heißen DEFAULT.HTM, DEFAULT-MORE.HTM und DEFAULT-EXCERPT.HTM. Alle drei verweisen auf die im übergeordneten Vezeichnis liegende Datei DEFAULT.CSS.


Rechtschreibprüfung

Rechtschreibprüfung

Mit der Rechtschreibprüfung können Sie Ihren Text auf Rechtschreibfehler untersuchen. Wie bei einer Textverarbeitung werden dabei solche Wörter moniert, die unbekannt sind. Sie können das betreffende Wort dann anpassen, ins Wörterbuch aufnehmen oder die Warnung ignorieren.

Rechtschreibprüfung starten

Starten lässt sich die Rechtschreibprüfung im Menü Extras oder über den betreffenden Button ( [image] ) auf der Buttonleiste. Wenn Sie vorher nur ein Wort oder einen Abschnitt markieren, wird nur dieser Teil geprüft, ansonsten wird immer der gesamte Text sowie der Titel untersucht. Auf unbekannte Wörter können Sie folgendermaßen reagieren:

Ignorieren

Das unbekannte Wort bleibt unverändert. Drücken Sie Immer, so gilt dies für den gesamten Text (was z.B. praktisch ist, wenn es sich um einen Namen handelt, der mehrmals im Text auftaucht).

Ersetzen

Für unbekannte Wörter werden meistens auch gleich Verbesserungsvorschläge gemacht. Wenn Sie einen der Vorschläge übernehmen wollen, dann markieren Sie ihn in der Liste. Ebenso ist es möglich, innerhalb des Textfeldes das Wort manuell anzupassen. Drücken Sie Immer, wird das unbekannte Wort innerhalb des gesamten Textes ersetzt.

Ins Wörterbuch aufnehmen

Durch diesen Befehl können Sie ein Wort dauerhaft ins Wörterbuch aufnehmen. Verwendet werden dabei die Benutzer-Wörterbücher, von denen Sie in den Optionen auch mehrere erstellen und aktivieren können.

Wörterbücher

Ob ein Wort bekannt oder unbekannt ist, hängt natürlich vom verwendeten Wörterbuch ab. Standardmäßig wird BlogDesk mit einem deutschen Wörterbuch ausgeliefert. Sie können aber durchaus auch Wörterbücher für andere Sprachen verwenden, die sich sogar gleichzeitg aktivieren lassen (Englisch, Französisch, Italienisch etc.). Diese finden Sie auf einer gesonderten Downloadseite für Wörterbücher.

Optionen

Während der Rechtschreibprüfung können Sie jederzeit die Optionen anpassen, die Sie sonst auch innerhalb der Programm-Optionen im Register Rechtschreibprüfung finden.

Wörter in GROSSBUCHSTABEN ignorieren

Sorgt dafür, dass Wörter, die nur aus Großbuchstaben bestehen, bei der Prüfung ignoriert werden.

Zahlen ignorieren

Sorgt dafür, dass Zahlen ignoriert werden.

Wörter mit Zahlen ignorieren

Sorgt dafür, dass Wörter ignoriert werden, die Zahlen enthalten.

Vor dem Veröffentlichen automatisch prüfen

Startet (auf Nachfrage) die Rechtschreibprüfung, bevor ein Beitrag endgültig veröffentlicht wird.

Wörterbücher - Standard

In dieser Liste werden die verfügbaren Standard-Wörterbücher aufgelistet. Aktivieren Sie hier die Wörterbücher, die bei der Rechtschreibprüfung beachtet werden sollen. Wenn Sie mehrere Wörterbücher aktivieren, verlangsamt das natürlich die Kontrolle.

Wörterbücher - Benutzer

Während der Rechtschreibprüfung können Sie unbekannte Wörter in ein Wörterbuch aufnehmen. Hier können Sie die dabei zu verwendenden Wörterbücher aktivieren und auch neue erstellen oder löschen.


Programm- und Anwenderverzeichnis

Programmverzeichnis

Im Programmverzeichnis liegen die zu BlogDesk gehörenden Programmdateien, die aktive Sprachdatei BLOGDESK.LNG, die Hilfedatei BLOGDESK.CHM sowie die spezielle Konfigurationsdatei BLOGDESK.CFG.

Falls Sie nicht wissen, um welches Verzeichnis es sich dabei handelt, können Sie es sich anzeigen lassen. Wählen Sie dafür im Menü Hilfe den Befehl Info und dann Weitere Infos.

Anwenderverzeichnis

Bei der Arbeit mit BlogDesk entstehen eine Reihe von Daten, z.B. die Blog-Konfiguration, die Optionen und archivierte Beiträge. All diese Anwenderdaten werden im Anwenderverzeichnis gespeichert, das wiederum mehrere Unterverzeichnisse enthält.

Standardmäßig befindet sich dieses Anwenderverzeichnis an einem Ort auf Ihrem Rechner, den Windows extra für solche Zwecke geschaffen hat: die zu jedem Anwender gehörenden Anwendungsdaten. Für den Anwender Carlo könnte das z.B. so aussehen:

C:\Dokumente und Einstellungen\Carlo\Anwendungsdaten\

Innerhalb dieses Ordners befindet sich das zu BlogDesk gehörende Verzeichnis, also der Ordner mit Ihren BlogDesk-Anwenderdaten:

C:\...\Carlo\Anwendungsdaten\BlogDesk\UserData

Normalerweise brauchen Sie sich um dieses Verzeichnis nicht weiter kümmern. Wenn Sie aber ein Backup Ihrer Daten erstellen oder diese auf einen anderen Rechner ü bertragen wollen, dann müssen Sie wissen, wo sich diese Daten befinden. Bei Bedarf können Sie das Anwenderverzeichnis auch an einen anderen Ort verlegen.

Sie können sich das aktuelle Anwenderverzeichnis anzeigen lassen, wenn Sie im Menü Hilfe den Befehl Info aufrufen und dann Weitere Infos wählen.

Anwenderverzeichnis anpassen

Bei Bedarf können Sie BlogDesk anweisen, ein anderes Verzeichnis zu verwenden. Das ist z.B. sinnvoll, wenn Sie Ihre Daten zentral auf einem Server ablegen oder auf einer bestimmten Partition sammeln, um ein Backup zu erleichtern.

Das Anwenderverzeichnis lässt sich durch einen entsprechenden Eintrag in der Datei BLOGDESK.CFG anpassen. Findet BlogDesk dort beim Programmstart einen Eintrag, wird dieser verwendet (statt des oben erwähnten Systemordners Anwendungsdaten).

Die Datei BLOGDESK.CFG befindet sich im Programmverzeichnis (siehe oben) und kann dort mit einem einfachen Texteditor (z.B. Notepad) bearbeitet werden. Anzupassen ist dabei der Eintrag UserPath in der Sektion [Main]. Das könnte dann anschließend z.B. so aussehen:

[Main]

UserPath=F:\MeineDaten\BlogDesk\UserData

Achten Sie beim Bearbeiten darauf, keine anderen Einträge versehentlich zu verändern. Wenn Sie wieder das ursprüngliche Anwenderverzeichnis verwenden wollen, müssen Sie die Zeile mit dem Eintrag UserPath wieder entfernen.

Komplette Verzeichnisstruktur

Um diesen Abschnitt brauchen Sie sich nicht weiter kümmern, er dient nur der Information. Aufgelistet werden hier Programm- und Anwenderverzeichnis mit ihren jeweiligen Unterverzeichnissen.

BlogDesk | Im Programmverzeichnis liegen die Programmdateien.
Default | Standarddateien, die beim Erstellen eines neuen Anwenders auf dessen Verzeichnisse verteilt werden.
Dictionaries | Die Standard-Wörterbücher für die Rechtschreibprü fung.
Language | Die verfügbaren Sprachdateien.
UserData | Im Anwenderverzeichnis liegen die zum Anwender gehörenden Dateien.
Blogs | Konfigurationsdateien für eingerichtete Blogs.
Dictionaries | Die Benutzer-Wö rterbü cher.
Draft | Gespeicherte, aber noch nicht publizierte Beiträge.
Extras | Dateien für Notizen, Textbausteine und Technorati-Tags.
Images | In den Beiträgen verwendete Bilder.
Sent | Archivierte Beiträge.
[Blogname] | Evtl. weitere Unterverzeichnisse zum Archivieren von Beiträgen, die auf dem entsprechenden Blog veröffentlicht wurden.
Template | Vorlagen und Master-Templates.


Daten sichern & übertragen

 Top Previous

Daten sichern

Um Datenverluste zu vermeiden (z.B. bei technischen Problemen, Plattencrash, Diebstahl etc.), sollten Sie auch die zu BlogDesk gehörenden Anwenderdaten regelmäßig sichern. Im Falle eines Verlustes können Sie dann die gesicherten Daten zurückholen - statt eines Totalverlustes sind Sie dann wenigstens auf dem Stand der letzten Sicherung.

Für ein komplettes Backup ist lediglich das Anwenderverzeichnis mit all seinen Unterverzeichnissen zu sichern sowie die Datei BLOGDESK.CFG im Programmverzeichnis.

Anwenderdaten übertragen

Wenn Sie einen neuen Rechner bekommen, werden Sie wahrscheinlich BlogDesk erneut installieren und Ihre alten Anwenderdaten übernehmen wollen. Gehen Sie dabei folgendermaßen vor:

· Sichern Sie wie oben beschrieben auf Ihrem bisherigen Rechner die zu BlogDesk gehörenden Anwenderdaten.
· Installieren Sie BlogDesk auf Ihrem neuen Rechner.
· Kopieren Sie die vorher gesicherten Anwenderdaten in die entsprechenden Verzeichnisse auf dem neuen Rechner.